Solution: Media Explorer States That My Zen Player/Device Not Connected ~ Creative Labs Zen MP3 Players Sound Blaster Card
Creative Labs Sale!
creative labs sale!
'Like' us to get latest Discount Coupons update and win prizes!->

Thursday, June 14, 2007

Solution: Media Explorer States That My Zen Player/Device Not Connected




Problem: It was working fine for a few months, but suddenly my Zen Micro Media Explorer says my player not connected. But it is connected! I tried reinstalling everything over and over again, but nothing still. I'm running winXP service pack 2.

Creative Media Explorer cannot connect
Solution: Click Start, (Settings), Control Panel, System, Hardware, and then Device Manager.
The MTP player should be listed under Windows Portable Devices as shown in the photo above.
Right click on the player listing and delete it. Reboot the PC with the Zen player still connected to your PC. Windows will find the MTP device which is your Zen player automatically. You will hear the lovely 'pop' sound and everything was fixed.

Having problem with your Zen? Click here to read more on myZenChecker

Need more help? Please post your questions/comments in
myCreative Fansite Forum. So that we can help you out. Thanks!

54 comments:

aplusj said...

I have a Vision M and it was working great, but now I can't get it to talk to my computers. I get the following message.

"One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it. For assistance in solving this problem, click this message."

I've seen other people have this problem on the forums, but there's no real solution. Device Manager doesn't even have a Windows Portable Devices section. Any help is appreciated.

PS - the device works. I can play songs and charge it, I just can't add new songs.

Creative Fan said...

you could use myZenChecker, http://xxmycreativexx.blogspot.com/2007/05/myzenchecker-tools-guide-to-problem.html to check. Are you using Win XP with SP2?

aplusj said...

Yes. I'm getting the following message:

INFO: You are using Microsoft Internet Explorer.
GOOD: Your Operating System is Windows XP
GOOD: You have Service Pack 2 installed
GOOD: You have an Intel Processor
GOOD: You have a Windows Platform

Why does it say Intel Processor when I have an AMD 64 chip inside?

Creative Fan said...

Its ok, i am also using AMD :) the intention here to verify that its a PC processor

Ronald said...

I just bought my Zen Vision M today, and my PC can't detect it. I tried connecting it at the back of the PC, but it still doesn't work. I tried to check the Device Manager, but it's not even there also.

Creative Fan said...

For the new Zen Vision M, you need to charge for at least 5hrs to get it recognised. Have you used the myZenChecker?

Anonymous said...

Sweet, helped thanks, i recently worked at a call center and knew how to do this but could remember how to get into the device manager -___-'.

aplusj said...

Has anyone figured out what causes the driver not to load. I've had this problem before and sent it into Creative and they fixed it. It was running great for several months then all of a sudden it stopped. I was wondering if it has anything to do with Microsoft updates.

Creative Fan said...

for my case, its just suddenly not detected and i had not done any microsoft update. But this solution has made my zen detected again by my PC :)

Anonymous said...

it works only for few seconds,after that my zen v plus can't be detected again by zen explorer
help me please

Creative Fan said...

do you have Win XP & SP2? if my tool didnt detected it, i suggest you reinstall SP2 again

Anonymous said...

i have just reinstalled SP2 but you tool still says it need to upgrade. any ideas?

Creative Fan said...

If you really sure SP2 is installed properly, then try & see if it will resolve your issue, if not can proceed with fix2 & fix3. Well, we experienced cases where the tool is correct in detecting the SP2 is not installed properly and a re-installation really solve the problem.

Anonymous said...

I tried every fix besides the windows vista one. the site still claims I don't have SP2 when I have already reinstalled it. I got the drivers again, I got the zenusb attachment. I have made progress though. It now charges and whenever I open zen vision M: media explorer it says 'docked' on the screen. But media explorer still says there's nothing connected. x___x

Creative Fan said...

You are making good progress, is it a new Zen Vision? let it charge for 5+hrs in order for your PC to recognise it

harlod malmsteen said...

thank you very much. this method worked to perfection. it's ridiculous, though that creative cant provide support nearly as good as a fansite provided.
fuck creative I ll make sure I never ever buy anything with a creative brand label on it.

Anonymous said...

thx guys I would be really lost without you. It is ridiculous though that creative cant support a service which is even nearly as good as this fan site.

Hence... FUCK creative I will never ever buy anything with a creative label on it ever!!

make sure all you guys do the same... boycott the motherfuckers, make them pay ofr not giving us dearly beloved customers enough attention!

thx my creativezenfansite.....FUCK YOU CREATIVE

Anonymous said...

I bought a Zen Vision M yesterday and I've installed all softwares in the CD, but my computer can't detect it. I let it charge for 8 hours in a USB port in the back of my PC, but nothing happens. I tried to install fix2 (myzen...something), but the program was just a WinRar which was with two files that opened and closed at once. Help !!

Creative Fan said...

does the tool states that your PC is Win XP with SP2? for fix2, you got to run the 'myzenusb.bat' and reboot with your zen connected

Anonymous said...

I have all the requirements for my ZEN Vision M, but my PC can't detect it. How can I charge my ZEN for 5+ hours to get it recognized by the PC when the blue light never flash. I've tried in USB in back and front, wall charging, trough Wii USB and changed USB cable. Can't I fix the problem without buying AC adapter. Can you please tell me exactly what to do with the myzenusb software after downloading it ?

chickrunner07 said...

I have a zen vision m and windows vista. My computer, creative media explorer, and windows media player 11 say that there is no player connected. I have tried Device Manager and reinstalling the computer. It charges it, however. Any suggestions?

Creative Fan said...

try using myZenChecker tool http://xxmycreativexx.blogspot.com/2007/05/myzenchecker-tools-guide-to-problem.html. post your questions at mycreative fansite forum.

Anonymous said...

none of these solutions worked for me. i run vista 32 and have a creative zen vision m. it used to work, now no longer. wonder if it's microsoft updates? not sure. zen charges but nothing else. so frustrated. wish i had an ipod...

Creative Fan said...

check out the forum, there are other solutions available http://xxmycreativexx.blogspot.com/2010/08/mycreative-fansite-forum.html

Anonymous said...

hi can you help me? i have a similar problem coz my os is vista 32bit and creative media source 5 cannot recognize my zen v:m 60gb i want to try the suggestion to uninstall my device in the control panel> device manager but i'm scared i might worsen the problem. the zen media explorer can recognize it but cannot add media or even sync. but if i click the browse media and paste a video it works. can you help me. i want to take advantAGE of my zen using the software thanks

mguj

Anonymous said...

Fix 2 worked. Thank you.

Anonymous said...

Ok, I have 2 Zen touch MP3 players. The screen went on one but still plays music and I'm able to get music on and off of it. Has anyone else had this problem and how did you fix it?
The other needs a new battery because it's not holding a charge and only plays when plugged in. Now I purchased a battery for it but can't get the back off the damn thing to save my life, any suggestions? I can't seem to get a # to call creative and get them fixed.

Sharon said...

This solution worked for me.
Thanks a lot. :)

akaswell said...

Can someone help? I am still having problems after following all of the directions...When I open device manager (with my zen plugged in and powered up) it still doesn't even recognize that it is there. There is no yellow triangle and it isn't even an option to uninstall, it simply doesn't show up! Grr I am so frustrated with this $300 paperweight

Anonymous said...

i can't find system after i'm in the control panel ><

Anonymous said...

I also have(had) this problem "vista home 32bit os" & it was an utter pain in the A** as i tried virtually all the quick fix methods.It just stopped working on its own one day, or so it seemed. 1st off not saying this is a universal fix, who knows if this problem was only perculiar to mine.(service pack 1 is also a known cause of this, but exhaust all alternatives before you try that)
Okay what causes this issue is usually always driver conflict with another usb device,check your list of installed programs from control panel if you have a "libusb-win32-filter-bin-0.1.10.1" applix or close i.e start by eliminating any usb required connectivity software there, so in my case,this was a sure no no for the zen's connectivity i had my laptop rigged with my ps3 pad which required it for psx & zsnes(check carefully if you have any of these), but an uninstall quickly remedied it without me even having to reboot (just uninstal the zen driver leave it plugged in & start eliminating possible causes, if & when u locate the culprit, it will start to work).So now my zen is working wonderfully again, quite perculiar isint it! this might help someone out there. might!

Anonymous said...

Ok I've tried everything other than rebooting and reformatting my Zen to get it to work. Now I've gotten the Google tool bar so I could get zenchecker.
it says I need xpsp2. Why would I need 2 when I'm on 3?!

INFO: You are using Microsoft Internet Explorer.
GOOD: Your Operating System is Windows XP
BAD: You do not have Service Pack 2 installed. Please refer to Fix1 to get it installed
GOOD: You have an Intel Processor
GOOD: You have a Windows Platform
BAD: You do not have Windows Media Player Version 10. Refer to Fix6 below.

Would my wmp version really make a difference to whether it is recognized or not?
This seems ridiculous!
All this work just to make the Zen vision M work.
What does rebooting do?
Will it erase my info?
Worst thing of all is that I have treasured family photos on there with no other backup. and now because of this ridiculous situation, my files may be lost.

it works fine other than it doesn't connect!

PLEASE HELP ME
flam4@hotmail.com

Sarah Marie said...

I've had my Zen Wav for over a year now. I've not had any problems until yesterday. I plugged the player into my USB port, preparing to add more music to it. I went to 'My Computer' to access the Zen Wav software. When I clicked on it, the program opened but nothing was clickable (all dimmed). So, I went the second route to access it through it being a 'Portable Device' and then I realized that my computer wasn't even recognizing it that way. So, I reset the player but no fix. Then I uninstalled/reinstalled the software but again, no fix. It does charge when it's plugged in, though and it works perfectly when I'm using the player. I'm using Vista but I don't think I can blame it on that because I've been successfully using the player with Vista since September. Obviously, it's past the warranty period at this point. I've left it plugged in, hoping it would evenually recognize it but nope. Any suggestions? Thanks so much!

Sincerely,
Sarah Marie

Anonymous said...

i just bought zen v plus player and my computer won't detect it.. i tried the solution thats explained above .. uninstalling it from device manager and restarting but then it appears that its detected just for a moment.. i downloaded firmware upgrade but i cant upgrade it becuse it says my player is not connected.. and im pretty shure i have upgradet my sp2 and everything.. please help I'm loosing my fucking mind..

aenpthokny said...

hey.. where can i find a download link for the media explorer?? i cant seem to find it in the creative site.. or maybe it has a different name there..

Jimmyboy88 said...

you can get it in our forums, in the member area

Anonymous said...

Hello,
today my Zen Vision:M frozed on welcome screen. I found a recovery mode - there try everything:reboot, clean up, formate all, erase firmware... When I conect it via USB cable, it docked and charged succesfully. But now I dont have any firmware on ZEN. I see it in Computer management-Portable devices. When I connect it - autorun statemen appears, but when I open it in Creative Media Explorer - it told me that is no player connected. The most problem is, i cant upgrade firmware through "ZENVisionM_30GB_PCFW_L21_1_62_02e". Do you have any idea? Thanks

Anonymous said...

The program dont want open!!! i can access enter directly mycomputer, it charge... but i can´t put nothing, no music, no videos!! my os is windows vista, what i can do?

Jimmyboy88 said...

if you have vista, check this solution http://www.mycreativefansite.com/2007/06/solution-windows-vista-cannot-recognise.html

for more answers pls refer to our forums or post your questions in our forums so that our experts will help you out

Elliott said...

my zen vision m refuses to be recognised by my new computer. I have Vista and WMP 11. Have lost the software disc: tried to download some but said wouldnt do it with a 64-bit something. Gone to device manager and tried there, it says: This device cannot start. (Code 10)Any suggestions please!!

Jimmyboy88 said...

check it out here http://forums.mycreativefansite.com/index.php?board=22.0

Rajvi said...

Thank you for your support. I just updated the software and it started syncing again. Thank you!

Jimmyboy88 said...

nice to hear that! :)

Anonymous said...

can someone please help me I was told I needed to reload firmware so I have wiped everything off ... I my vision m is now stuck in recovery mode and when I try and reinstall firmware online it says no player connected yet it shows up in my devices ... please help

Jimmyboy88 said...

use myzenchecker, its in the forum to get your pc recognize it first before you can install your firmware again

Anonymous said...

The same thing happend with me i reinstalled the device and booted my pc.The good thing is that the synchroniztion is working but not the zen media explorer in the my computer folder it still says your zen is not connected.Can anyone help Me???

Anonymous said...

THANK YOU! This solution worked for me :D

Anonymous said...

THANK YOU SOOOOOOOOOO MUCH. I thought that i need to throw away my ZEN V M as it is not sold in India and i had it for last four years while in UAE.

Jimmyboy88 said...

nice!

Anonymous said...

worked like a charm.... thanks very much

Anonymous said...

Excellent blοg here! Аlso your wеbsite
lоads up veгy faѕt! What wеb hοst are yοu using?
Can I get your affiliаte link to your host?
I wish my web site loaԁed up аs quickly аs
yοurѕ lol

Feel free to ѕurf to my web site ..
. link building service

Anonymous said...

Greybаck hard cash Pasѕes out cash Drawегs And гесеption Printers ѕubstantiνe& backing For Any design baѕed On Sales And immеdiatе ρaymentAdvertisers Hoω Tο Payday
Your Wedding ceremony Demoсrats fall out Obama's atomic number 82Your Online cash request debt Collectors Are Called Off Inimpudent the great unwashed stimulate Payday Loans Online marketing Watches Shoes Uniforms Online Article2012 cause Payday - Car Loan Payday throw out: When To

Here is my site ... payday loan

Anonymous said...

angriness At Wasserman Schultz To Grow Payday Loans Online As Irene Approachessome Options For asset Payday And
Find Jobs In Americayearbook Financial medical exam End Of immediate payment:
U S Government StarbucksFor pocket-size business organisation
Centering How To retrace payday loan stream Andpersonal Online Payday Loan leger Reappraisal - Simplest Way To lengthy fall offCultivate quint respectable disbursal Habits To salve Money By investment
My webpage :: payday loan

Anonymous said...

Hi there, after reading this amazing post i am also happy to share my knowledge here with mates.



My weblog; wiki.nexua.org

Post a Comment

Need more help? Please post your questions/comments in myCreative Fansite Forum. So that we can help you out.

myCreative Fansite Store (fulfilled by Amazon!)
Store | Buy @ US | Buy @ UK

Zen Forums
MP3 Player | ZEN Tips, Tricks, Hacks | ZEN X-Fi Style / 100 / 300 | ZEN X-Fi2 | ZEN X-Fi | ZEN Mozaic / EZ100 / EZ300 | ZEN / MX | ZEN V / Plus | ZEN Vision M | ZEN Vision W | ZEN Micro / Photo | ZEN Stone / Plus | MuVo / T100 / T200 | Nomad Jukebox Zen Xtra / MuVo | Zii Egg | ZEN Touch 2 ZEN Style M100 / M300

Tablet Forums
ZiiO Tablet

Other MP3 Player Forums
Microsoft Zune / HD | SanDisk Sansa

Sound Blaster Forums
Sound Blaster Card | Audigy

Creative Forums
Creative Technology | Auction Buy Sell | Vado HD / Webcam | Creative Speaker Creative Headphone Headset

Other Forums
Our Site News, Announcement | Chit Chat | Counseling Psychology

Popular Posts



Recent Posts



Recent Comments